
<!DOCTYPE html>
<html class="no-js" lang="en-US">
<head>
	<meta charset="UTF-8">
	<!-- Always force latest IE rendering engine (even in intranet) & Chrome Frame -->
	<!--[if IE ]>
	<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
	<![endif]-->
	<link rel="profile" href="http://gmpg.org/xfn/11" />
	
        
        
        
                    <meta name="viewport" content="width=device-width, initial-scale=1">
            <meta name="apple-mobile-web-app-capable" content="yes">
            <meta name="apple-mobile-web-app-status-bar-style" content="black">
        
        
        <meta itemprop="name" content="The Omega Student Newspaper Ω" />
        <meta itemprop="url" content="http://truomega.ca" />

                                                <meta itemprop="creator accountablePerson" content="Justin Moore" />
                    	<link rel="pingback" href="http://truomega.ca/xmlrpc.php" />
	<title>The final rundown of Kamloops candidates in B.C. General Election &#8211; The Omega Student Newspaper Ω</title>
<script type="text/javascript">document.documentElement.className = document.documentElement.className.replace( /\bno-js\b/,'js' );</script><link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s.gravatar.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The Omega Student Newspaper Ω &raquo; Feed" href="http://truomega.ca/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Omega Student Newspaper Ω &raquo; Comments Feed" href="http://truomega.ca/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Omega Student Newspaper Ω &raquo; The final rundown of Kamloops candidates in B.C. General Election Comments Feed" href="http://truomega.ca/2020/10/19/the-final-rundown-of-kamloops-candidates-in-b-c-general-election/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11.2.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11.2.0\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/truomega.ca\/wp-includes\/js\/wp-emoji-release.min.js"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='http://truomega.ca/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='http://truomega.ca/wp-content/plugins/contact-form-7/includes/css/styles.css' type='text/css' media='all' />
<link rel='stylesheet' id='perfect-pullquotes-styles-css'  href='http://truomega.ca/wp-content/plugins/perfect-pullquotes/perfect-pullquotes.css' type='text/css' media='all' />
<link rel='stylesheet' id='Tippy-css'  href='http://truomega.ca/wp-content/plugins/tippy/jquery.tippy.css' type='text/css' media='all' />
<link rel='stylesheet' id='wordpress-popular-posts-css-css'  href='http://truomega.ca/wp-content/themes/omega2015/wpp.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-polls-css'  href='http://truomega.ca/wp-content/plugins/wp-polls/polls-css.css' type='text/css' media='all' />
<style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background-image: url('http://truomega.ca/wp-content/plugins/wp-polls/images/default/pollbg.gif');
	border: 1px solid #c8c8c8;
}

</style>
<link rel='stylesheet' id='parent-style-css'  href='http://truomega.ca/wp-content/themes/mts_best/style.css' type='text/css' media='all' />
<!-- Inline jetpack_facebook_likebox -->
<style id='jetpack_facebook_likebox-inline-css' type='text/css'>
.widget_facebook_likebox {
	overflow: hidden;
}

</style>
<link rel='stylesheet' id='tablepress-default-css'  href='http://truomega.ca/wp-content/tablepress-combined.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='tipsy-css'  href='http://truomega.ca/wp-content/plugins/wp-shortcode/css/tipsy.css' type='text/css' media='all' />
<link rel='stylesheet' id='mts_wpshortcodes-css'  href='http://truomega.ca/wp-content/plugins/wp-shortcode/css/wp-shortcode.css' type='text/css' media='all' />
<link rel='stylesheet' id='best-stylesheet-css'  href='http://truomega.ca/wp-content/themes/omega2015/style.css' type='text/css' media='all' />
<style id='best-stylesheet-inline-css' type='text/css'>

        body {background-color:#ffffff;background-image:url(http://truomega.ca/wp-content/themes/mts_best/images/nobg.png);}
        .main-header {background-color:#ffffff;background-image:url(http://truomega.ca/wp-content/themes/mts_best/images/nobg.png);}
        footer-carousel-wrap {background-color:#3498db; }
        footer {background-color:#eeeeee;background-image:url(http://truomega.ca/wp-content/themes/mts_best/images/nobg.png);}
        footer > .copyrights {background-color:#33567d;}
        .pace .pace-progress, .mobile-menu-wrapper, .owl-carousel .owl-nav > div, #top-navigation li:hover a, #header nav#top-navigation ul ul li, a#pull, .secondary-navigation, #move-to-top,.mts-subscribe input[type='submit'],input[type='submit'],#commentform input#submit,.contactform #submit,.pagination a,.fs-pagination a,.header-search .ajax-search-results-container,#load-posts a,#fs2_load_more_button,#wp-calendar td a,#wp-calendar caption,#wp-calendar #prev a:before,#wp-calendar #next a:before, .tagcloud a, #tags-tab-content a, #wp-calendar thead th.today, .slide-title, .slidertitle, #header nav#navigation ul ul li, .thecategory a, #wp-calendar td a:hover, #wp-calendar #today, .widget .wpt-pagination a, .widget .wpt_widget_content #tags-tab-content ul li a, .widget .wp_review_tab_widget_content .wp-review-tab-pagination a, .ajax-search-meta .results-link, .post-day .review-total-only, .woocommerce a.button, .woocommerce-page a.button, .woocommerce button.button, .woocommerce-page button.button, .woocommerce input.button, .woocommerce-page input.button, .woocommerce #respond input#submit, .woocommerce-page #respond input#submit, .woocommerce #content input.button, .woocommerce-page #content input.button, .woocommerce nav.woocommerce-pagination ul li a, .woocommerce-page nav.woocommerce-pagination ul li a, .woocommerce #content nav.woocommerce-pagination ul li a, .woocommerce-page #content nav.woocommerce-pagination ul li a, .woocommerce .bypostauthor:after, #searchsubmit, .woocommerce nav.woocommerce-pagination ul li a:hover, .woocommerce-page nav.woocommerce-pagination ul li a:hover, .woocommerce #content nav.woocommerce-pagination ul li a:hover, .woocommerce-page #content nav.woocommerce-pagination ul li a:hover, .woocommerce nav.woocommerce-pagination ul li a:focus, .woocommerce-page nav.woocommerce-pagination ul li a:focus, .woocommerce #content nav.woocommerce-pagination ul li a:focus, .woocommerce-page #content nav.woocommerce-pagination ul li a:focus, .woocommerce a.button, .woocommerce-page a.button, .woocommerce button.button, .woocommerce-page button.button, .woocommerce input.button, .woocommerce-page input.button, .woocommerce #respond input#submit, .woocommerce-page #respond input#submit, .woocommerce #content input.button, .woocommerce-page #content input.button, .widget_product_search input[type='submit'] {background: #155b9b; color: #fff; }
        .header-search #s,nav a.toggle-mobile-menu, .tab_widget ul.wps_tabs li, .wpt_widget_content .tab_title.selected a, .widget_wp_review_tab .tab_title.selected a {background: #155b9b !important;}
        #wp-calendar thead th.today { border-color: #155b9b; }
        a, a:hover,.title a:hover,.post-data .post-title a:hover,.post-title a:hover,.post-info a:hover,.entry-content a,.textwidget a,.reply a,.comm,.fn a,.comment-reply-link, .entry-content .singleleft a:hover, #footer-post-carousel .owl-nav div {color:#155b9b;}
        .post-box .review-total-only .review-result-wrapper .review-result i {color:#155b9b!important;}
        footer > .footer-carousel-wrap { background: #3498db; }
        
        .shareit { top: 373px; left: auto; z-index: 0; margin: 0 0 0 -110px; width: 100px; position: fixed; padding: 0; border:none; border-right: 0;}
        .share-item {margin: 2px;}
        
        .bypostauthor .fn:after { content: "Author"; position: absolute; left: 0px; top: 0px; padding: 0px 10px; background: #444; color: #FFF; border-radius: 3px; }
        
        
        
            
</style>
<link rel='stylesheet' id='fontawesome-css'  href='http://truomega.ca/wp-content/themes/mts_best/css/font-awesome.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='responsive-css'  href='http://truomega.ca/wp-content/themes/mts_best/css/responsive.css' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='http://truomega.ca/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://truomega.ca/wp-content/plugins/jetpack/css/jetpack.css' type='text/css' media='all' />
<script type='text/javascript' src='http://truomega.ca/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='http://truomega.ca/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<script type='text/javascript' src='http://truomega.ca/wp-content/plugins/tippy/jquery.tippy.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpp_params = {"sampling_active":"","sampling_rate":"100","ajax_url":"http:\/\/truomega.ca\/wp-admin\/admin-ajax.php","action":"update_views_ajax","ID":"20602","token":"0c9a09416d"};
/* ]]> */
</script>
<script type='text/javascript' src='http://truomega.ca/wp-content/plugins/wordpress-popular-posts/public/js/wpp.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var mts_customscript = {"responsive":"1","nav_menu":"secondary"};
/* ]]> */
</script>
<script type='text/javascript' async="async" src='http://truomega.ca/wp-content/themes/mts_best/js/customscript.js'></script>
<script type='text/javascript' src='http://truomega.ca/wp-content/plugins/wp-shortcode/js/jquery.tipsy.js'></script>
<script type='text/javascript' src='http://truomega.ca/wp-content/plugins/wp-shortcode/js/wp-shortcode.js'></script>
<link rel='https://api.w.org/' href='http://truomega.ca/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://truomega.ca/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://truomega.ca/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='The rundown on voting in the Provincial General Election' href='http://truomega.ca/2020/10/14/the-rundown-on-voting-in-the-provincial-general-election/' />
<meta name="generator" content="WordPress 5.1.6" />
<link rel="canonical" href="http://truomega.ca/2020/10/19/the-final-rundown-of-kamloops-candidates-in-b-c-general-election/" />
<link rel='shortlink' href='https://wp.me/p3PeAF-5mi' />
<link rel="alternate" type="application/json+oembed" href="http://truomega.ca/wp-json/oembed/1.0/embed?url=http%3A%2F%2Ftruomega.ca%2F2020%2F10%2F19%2Fthe-final-rundown-of-kamloops-candidates-in-b-c-general-election%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://truomega.ca/wp-json/oembed/1.0/embed?url=http%3A%2F%2Ftruomega.ca%2F2020%2F10%2F19%2Fthe-final-rundown-of-kamloops-candidates-in-b-c-general-election%2F&#038;format=xml" />
<link rel="alternate" type="application/rss+xml" title="The Omega Student Newspaper Ω GeoRSS-Feed" href="http://truomega.ca/wp-content/plugins/leaflet-maps-marker/leaflet-georss.php?layer=all" />

            <script type="text/javascript">
                jQuery(document).ready(function() {
                    jQuery('.tippy').tippy({ position: "link", offsetx: 0, offsety: 10, closetext: "X", hidedelay: 700, showdelay: 100, calcpos: "parent", showspeed: 200, hidespeed: 200, showtitle: true, hoverpopup: true, draggable: true, dragheader: true, multitip: false, autoshow: false, showheader: true, showclose: true, htmlentities: false });
                });
            </script>
        
<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<link rel='dns-prefetch' href='//jetpack.wordpress.com'/>
<link rel='dns-prefetch' href='//s0.wp.com'/>
<link rel='dns-prefetch' href='//s1.wp.com'/>
<link rel='dns-prefetch' href='//s2.wp.com'/>
<link rel='dns-prefetch' href='//public-api.wordpress.com'/>
<link rel='dns-prefetch' href='//0.gravatar.com'/>
<link rel='dns-prefetch' href='//1.gravatar.com'/>
<link rel='dns-prefetch' href='//2.gravatar.com'/>
<link href="//fonts.googleapis.com/css?family=Roboto:700|Biryani:200|PT+Sans:normal|Cabin+Condensed:700|Roboto:normal|Cabin+Condensed:600|Cabin+Condensed:500&amp;subset=latin" rel="stylesheet" type="text/css">
<style type="text/css">
#logo a { font-family: 'Roboto'; font-weight: 700; font-size: 36px; color: #3498db;text-transform: uppercase; }
.menu li, .menu li a { font-family: 'Biryani'; font-weight: 200; font-size: 15px; color: #ffffff;text-transform:uppercase; }
body { font-family: 'PT Sans', Helvetica, Arial, sans-serif; font-weight: normal; font-size: 16px; color: #444444; }
.post-data .post-title a, #comments-tab-content a { font-family: 'Cabin Condensed'; font-weight: 700; font-size: 19px; color: #444444;text-transform:none; }
.hentry .entry-title { font-family: 'Cabin Condensed'; font-weight: 700; font-size: 33px; color: #444444;text-transform: none; }
#sidebars .widget { font-family: 'Roboto'; font-weight: normal; font-size: 15px; color: #444444; }
.footer-widgets { font-family: 'Roboto'; font-weight: normal; font-size: 15px; color: #444444; }
h1 { font-family: 'Cabin Condensed'; font-weight: 700; font-size: 30px; color: #444444; }
h2 { font-family: 'Cabin Condensed'; font-weight: 700; font-size: 25px; color: #444444; }
h3 { font-family: 'Cabin Condensed'; font-weight: 700; font-size: 20px; color: #444444; }
h4 { font-family: 'Cabin Condensed'; font-weight: 700; font-size: 18px; color: #444444; }
h5 { font-family: 'Cabin Condensed'; font-weight: 600; font-size: 15px; color: #444444; }
h6 { font-family: 'Cabin Condensed'; font-weight: 500; font-size: 13px; color: #444444; }
</style>
<script type="application/ld+json">
{
    "@context": "http://schema.org",
    "@type": "BlogPosting",
    "mainEntityOfPage": {
        "@type": "WebPage",
        "@id": "http://truomega.ca/2020/10/19/the-final-rundown-of-kamloops-candidates-in-b-c-general-election/"
    },
    "headline": "The final rundown of Kamloops candidates in B.C. General Election  ",
    "image": {
        "@type": "ImageObject",
        "url": "http://truomega.ca/wp-content/uploads/2020/10/119905121_10158552387981287_8853202147978197337_o.jpg",
        "width": 1200,
        "height": 675
    },
    "datePublished": "2020-10-19T15:11:20-0700",
    "dateModified": "2020-10-19T15:11:20+0000",
    "author": {
        "@type": "Person",
        "name": "Justin Moore"
    },
    "publisher": {
        "@type": "Organization",
        "name": "The Omega Student Newspaper Ω",
        "logo": {
            "@type": "ImageObject",
            "url": "http://truomega.ca/wp-content/uploads/2015/09/omegaheader3.png",
            "width": 550,
            "height": 152
        }
    },
    "description": "With polls closing at the end of the week, he’s the list of candidates for both Kamloops ridings"
}
</script>

<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="The final rundown of Kamloops candidates in B.C. General Election" />
<meta property="og:url" content="http://truomega.ca/2020/10/19/the-final-rundown-of-kamloops-candidates-in-b-c-general-election/" />
<meta property="og:description" content="With polls closing at the end of the week, he’s the list of candidates for both Kamloops ridings" />
<meta property="article:published_time" content="2020-10-19T22:11:20+00:00" />
<meta property="article:modified_time" content="2020-10-19T22:11:20+00:00" />
<meta property="og:site_name" content="The Omega Student Newspaper Ω" />
<meta property="og:image" content="http://truomega.ca/wp-content/uploads/2020/10/119905121_10158552387981287_8853202147978197337_o.jpg" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="675" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:text:title" content="The final rundown of Kamloops candidates in B.C. General Election" />
<meta name="twitter:image" content="http://truomega.ca/wp-content/uploads/2020/10/119905121_10158552387981287_8853202147978197337_o.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />
</head>
<body id ="blog" class="post-template-default single single-post postid-20602 single-format-standard main" itemscope itemtype="http://schema.org/WebPage">
	<div class="main-container-wrap">
		<header class="main-header">
			<div id="header">
				<div class="container">
					<div class="header-inner">
						<div class="logo-wrap">
						<div class="toprightmenu_container_class">
							<div class="toprightmenu_class"><ul id="menu-top-right-header-menu" class="menu"><li id="menu-item-9723" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-9723"><a href="http://truomega.ca/contact-us/">Contact Us</a></li>
<li id="menu-item-9724" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-9724"><a href="http://truomega.ca/about/">About</a></li>
<li id="menu-item-19111" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19111"><a href="http://truomega.ca/about/advertising/">Advertising</a></li>
</ul></div>														<span class="topright_date">October 19, 2020</span>
						</div>
																									<h2 id="logo" class="image-logo">
											<a href="http://truomega.ca"><img src="http://truomega.ca/wp-content/uploads/2015/09/omegaheader3.png" alt="The Omega Student Newspaper Ω"></a>
										</h2><!-- END #logo -->
																					</div>
											</div>
				</div><!--.container-->
				
													<div class="secondary-navigation">
									<div class="container clearfix">
						<nav id="navigation" class="clearfix">
							<a href="#" class="toggle-mobile-menu">Menu</a>
															<ul id="menu-main-menu" class="menu clearfix"><li id="menu-item-3890" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-3890"><a href="http://truomega.ca/category/news/">News</a></li>
<li id="menu-item-3891" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3891"><a href="http://truomega.ca/category/culture/">Culture</a></li>
<li id="menu-item-3892" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3892"><a href="http://truomega.ca/category/sports/">Sports</a></li>
<li id="menu-item-19107" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19107"><a href="http://truomega.ca/category/op-ed/">Opinion</a></li>
<li id="menu-item-19113" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-19113"><a href="http://truomega.ca/about/">About</a>
<ul class="sub-menu">
	<li id="menu-item-19126" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19126"><a href="http://truomega.ca/contact-us/">Contact Us</a></li>
	<li id="menu-item-19125" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19125"><a href="http://truomega.ca/staff/">Staff</a></li>
	<li id="menu-item-19127" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19127"><a href="http://truomega.ca/contributor-and-submission-guidelines/">Contributor Guidelines</a></li>
	<li id="menu-item-19128" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19128"><a href="http://truomega.ca/about/advertising/">Advertising</a></li>
</ul>
</li>
<li id="menu-item-19114" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19114"><a href="http://truomega.ca/work/"><i class="fa fa-plus"></i> We&#8217;re Hiring</a></li>
</ul>													</nav>
						<div class="c_menusearch"><form method="get" id="searchform" class="search-form" action="http://truomega.ca" _lpchecked="1">
	<fieldset>
		<input type="text" name="s" id="s" value="" placeholder="Search the site"  />
		<button id="search-image" class="sbutton" type="submit" value="">
	    		<i class="fa fa-search"></i>
	    	</button>
	</fieldset>
</form>
</div>
					</div><!--.container-->
					</div>
				
			</div><!--#header-->
		</header>
		<div class="main-container"><div id="page" class="single">
		<article class="article">
		<div id="content_box" >
							<div id="post-20602" class="g post post-20602 type-post status-publish format-standard has-post-thumbnail hentry category-news has_thumb">
					<div class="single_post">
																		<header>
							<h1 class="title single-title entry-title">The final rundown of Kamloops candidates in B.C. General Election</h1>
							<h3 class="subhead-plugin-class">With polls closing at the end of the week, he’s the list of candidates for both Kamloops ridings</h3>
										<div class="post-info">
                                <span class="thecategory"><a href="http://truomega.ca/category/news/" title="View all posts in News">News</a></span>
                            <span class="thetime updated"><i class="fa fa-clock-o"></i> <span>Oct. 19, 2020</span></span>
                            <span class="theauthor"><i class="fa fa-user"></i> <span><a href="http://truomega.ca/author/justin-moore/" title="Posts by Justin Moore" rel="author">Justin Moore</a></span></span>
                            			</div>
								</header><!--.headline_area-->
						<div class="post-single-content box mark-links entry-content">
														
                            														<p>Voting day for the 2020 British Columbia General Election is quickly approaching on Saturday, Oct. 24. With advance polling stations closing on Oct. 21 at 8 p.m., this will be the last opportunity for voters to cast their ballots.</p>
<p>This week marks the one month date since the snap election was called by B.C. NDP leader John Horgan. Since September, leaders of each of the provincial parties have scrambled together their platforms and candidates for each electoral district.</p>
<p>In Kamloops, the two electoral districts, Kamloops-North Thompson and Kamloops-South Thompson have a combined total of eight candidates.</p>
<h3>Kamloops-North Thompson</h3>
<p><strong>Dennis Giesbrecht:</strong> B.C. Conservative Party<br />
A previous contender for City Council in 2018, Giesbrecht&#8217;s platform includes the privatization of car insurance, the dismissal of B.C.&#8217;s carbon tax, a tax-free environmental plan and further resource development.</p>
<p><strong>Sadie Hunter:</strong> B.C. NDP<br />
Elected to City Council in 2018, Hunter was also recently elected as a Union of B.C. Municipalities director at large. Hunter is a newcomer to the party but remains focused on bringing attention to Kamloops and smaller communities within the riding.</p>
<p><strong>Thomas Martin:</strong> B.C. Green Party<br />
A candidate with extensive wildfire-forestry related expertise. With experience as a wildfire fighter, Martin is currently working as a wildfire project manager for Cabin Resource Management. Issues and policies surrounding housing affordability, the opioid crisis and the COVID-19 pandemic are motions he&#8217;d like to see passed at a provincial level.</p>
<p><strong>Peter Milobar:</strong> B.C. Liberal Party<br />
Milobar is the current seat holder for the riding, earning his seat in 2017. Milobar served as a city councillor for two terms and as mayor for three. He has also worked on the BC Transit Board of Directors, at PRIMECorp, and on the Local Government Contract Management Committee.</p>
<p><strong>Brandon Russell:</strong> Independent<br />
The 19-year-old independent is looking to represent the voices of young people as an MLA if elected. Addressing climate change and enhancing education, especially during the COVID-19 pandemic, was at the top of Russell&#8217;s agenda.</p>
<h3>Kamloops-South Thompson</h3>
<p><strong>Dan Hines:</strong> B.C. Green Party<br />
A previous candidate for the Kamloops-North Thompson riding in 2017, receiving 20 per cent of the vote, Hines is an Anglican priest and works as an international leadership consultant and workshop facilitator. Hines hopes to see a more collaborative approach to governance.</p>
<p><strong>Anna Thomas:</strong> B.C. NDP<br />
President of the B.C. Native Women&#8217;s Association and member of the Lytton and Peguis First Nations, Thomas brings her passion for social justice and activism to the party, advocating for Indigenous women and girls, ending violence against women, social housing and mental health.</p>
<p><strong>Todd Stone:</strong> B.C. Liberals<br />
The current MLA for the Kamloops-South Thompson, Stone took office in 2013 and has served as Minister of Transport and Infrastructure under the B.C. Liberal government.</p>
<p>For more information on where to find a polling station, click <a href="https://elections.bc.ca/voting/where-to-vote/" target="_blank" rel="noopener noreferrer">here</a>. For further questions regarding the provincial election click <a href="https://elections.bc.ca/voting/voting-safely-and-covid-19/" target="_blank" rel="noopener noreferrer">here</a>.</p>

<script type="text/javascript">
jQuery(document).ready(function($) {
    $.post('http://truomega.ca/wp-admin/admin-ajax.php', {action: 'mts_view_count', id: '20602'});
});
</script><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this story:</h3><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-20602" class="share-facebook sd-button share-icon" href="http://truomega.ca/2020/10/19/the-final-rundown-of-kamloops-candidates-in-b-c-general-election/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-20602" class="share-twitter sd-button share-icon" href="http://truomega.ca/2020/10/19/the-final-rundown-of-kamloops-candidates-in-b-c-general-election/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-reddit"><a rel="nofollow" data-shared="" class="share-reddit sd-button share-icon" href="http://truomega.ca/2020/10/19/the-final-rundown-of-kamloops-candidates-in-b-c-general-election/?share=reddit" target="_blank" title="Click to share on Reddit"><span>Reddit</span></a></li><li class="share-email"><a rel="nofollow" data-shared="" class="share-email sd-button share-icon" href="http://truomega.ca/2020/10/19/the-final-rundown-of-kamloops-candidates-in-b-c-general-election/?share=email" target="_blank" title="Click to email this to a friend"><span>Email</span></a></li><li class="share-print"><a rel="nofollow" data-shared="" class="share-print sd-button share-icon" href="http://truomega.ca/2020/10/19/the-final-rundown-of-kamloops-candidates-in-b-c-general-election/#print" target="_blank" title="Click to print"><span>Print</span></a></li><li><a href="#" class="sharing-anchor sd-button share-more"><span>More</span></a></li><li class="share-end"></li></ul><div class="sharing-hidden"><div class="inner" style="display: none;"><ul><li class="share-linkedin"><a rel="nofollow" data-shared="sharing-linkedin-20602" class="share-linkedin sd-button share-icon" href="http://truomega.ca/2020/10/19/the-final-rundown-of-kamloops-candidates-in-b-c-general-election/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span>LinkedIn</span></a></li><li class="share-google-plus-1"><a rel="nofollow" data-shared="sharing-google-20602" class="share-google-plus-1 sd-button share-icon" href="http://truomega.ca/2020/10/19/the-final-rundown-of-kamloops-candidates-in-b-c-general-election/?share=google-plus-1" target="_blank" title="Click to share on Google+"><span>Google</span></a></li><li class="share-end"></li><li class="share-pocket"><a rel="nofollow" data-shared="" class="share-pocket sd-button share-icon" href="http://truomega.ca/2020/10/19/the-final-rundown-of-kamloops-candidates-in-b-c-general-election/?share=pocket" target="_blank" title="Click to share on Pocket"><span>Pocket</span></a></li><li class="share-tumblr"><a rel="nofollow" data-shared="" class="share-tumblr sd-button share-icon" href="http://truomega.ca/2020/10/19/the-final-rundown-of-kamloops-candidates-in-b-c-general-election/?share=tumblr" target="_blank" title="Click to share on Tumblr"><span>Tumblr</span></a></li><li class="share-end"></li><li class="share-pinterest"><a rel="nofollow" data-shared="sharing-pinterest-20602" class="share-pinterest sd-button share-icon" href="http://truomega.ca/2020/10/19/the-final-rundown-of-kamloops-candidates-in-b-c-general-election/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span>Pinterest</span></a></li><li class="share-end"></li></ul></div></div></div></div></div>														
							
                            						</div><!--.post-content box mark-links-->
					</div><!--.single_post-->
                    						<!-- Start Related Posts -->
						<div class="related-posts"><div class="postauthor-top"><h3>Related</h3></div><ul>							<li class="post-box horizontal-small">
								<div class="horizontal-container">
									<div class="horizontal-container-inner">
										<div class="post-img">
											<a rel="nofollow" href="http://truomega.ca/2020/03/11/tru-modern-marketing-club-hosted-annual-gala/" title="TRU Modern Marketing club hosted annual gala">
												<img width="115" height="115" src="http://truomega.ca/wp-content/uploads/2020/03/IMG_1537-115x115.jpg" class="attachment-best-widgetthumb size-best-widgetthumb wp-post-image" alt="" title="" />											</a>
										</div>
										<div class="post-data">
											<div class="post-data-container">
												<div class="post-title">
													<a href="http://truomega.ca/2020/03/11/tru-modern-marketing-club-hosted-annual-gala/" title="TRU Modern Marketing club hosted annual gala">TRU Modern Marketing club hosted annual gala</a>
												</div>
												<div class="post-info">
													<span class="thetime updated">Mar. 11, 2020</span>
													<span class="thecomment"><i class="fa fa-comments"></i> <a rel="nofollow" href="http://truomega.ca/2020/03/11/tru-modern-marketing-club-hosted-annual-gala/#respond">0</a></span>
												</div>
											</div>
										</div>
									</div>
								</div>
							</li>
														<li class="post-box horizontal-small">
								<div class="horizontal-container">
									<div class="horizontal-container-inner">
										<div class="post-img">
											<a rel="nofollow" href="http://truomega.ca/2020/09/16/youve-probably-noticed-some-change-around-campus/" title="You&#8217;ve probably noticed some change around campus">
												<img width="115" height="115" src="http://truomega.ca/wp-content/uploads/2020/09/Photo-2-115x115.png" class="attachment-best-widgetthumb size-best-widgetthumb wp-post-image" alt="" title="" srcset="http://truomega.ca/wp-content/uploads/2020/09/Photo-2-115x115.png 115w, http://truomega.ca/wp-content/uploads/2020/09/Photo-2-150x150.png 150w, http://truomega.ca/wp-content/uploads/2020/09/Photo-2-400x400.png 400w, http://truomega.ca/wp-content/uploads/2020/09/Photo-2-768x768.png 768w, http://truomega.ca/wp-content/uploads/2020/09/Photo-2-800x800.png 800w, http://truomega.ca/wp-content/uploads/2020/09/Photo-2.png 1050w" sizes="(max-width: 115px) 100vw, 115px" />											</a>
										</div>
										<div class="post-data">
											<div class="post-data-container">
												<div class="post-title">
													<a href="http://truomega.ca/2020/09/16/youve-probably-noticed-some-change-around-campus/" title="You&#8217;ve probably noticed some change around campus">You&#8217;ve probably noticed some change around campus</a>
												</div>
												<div class="post-info">
													<span class="thetime updated">Sep. 16, 2020</span>
													<span class="thecomment"><i class="fa fa-comments"></i> <a rel="nofollow" href="http://truomega.ca/2020/09/16/youve-probably-noticed-some-change-around-campus/#respond">0</a></span>
												</div>
											</div>
										</div>
									</div>
								</div>
							</li>
														<li class="post-box horizontal-small">
								<div class="horizontal-container">
									<div class="horizontal-container-inner">
										<div class="post-img">
											<a rel="nofollow" href="http://truomega.ca/2020/09/09/tru-receives-100-per-cent-federal-funding-for-research-projects/" title="TRU receives 100 per cent federal funding for research projects">
												<img width="115" height="115" src="http://truomega.ca/wp-content/uploads/2019/10/Logos-01_-TRU_Logo_Left_900px37269-115x115.png" class="attachment-best-widgetthumb size-best-widgetthumb wp-post-image" alt="" title="" />											</a>
										</div>
										<div class="post-data">
											<div class="post-data-container">
												<div class="post-title">
													<a href="http://truomega.ca/2020/09/09/tru-receives-100-per-cent-federal-funding-for-research-projects/" title="TRU receives 100 per cent federal funding for research projects">TRU receives 100 per cent federal funding for research projects</a>
												</div>
												<div class="post-info">
													<span class="thetime updated">Sep. 9, 2020</span>
													<span class="thecomment"><i class="fa fa-comments"></i> <a rel="nofollow" href="http://truomega.ca/2020/09/09/tru-receives-100-per-cent-federal-funding-for-research-projects/#respond">0</a></span>
												</div>
											</div>
										</div>
									</div>
								</div>
							</li>
														<li class="post-box horizontal-small">
								<div class="horizontal-container">
									<div class="horizontal-container-inner">
										<div class="post-img">
											<a rel="nofollow" href="http://truomega.ca/2020/06/30/b-c-government-announces-6-15-million-funding-for-indigenous-initiatives-in-public-universities/" title="B.C. Government announces $6.15 million funding for Indigenous initiatives in public universities">
												<img width="115" height="115" src="http://truomega.ca/wp-content/uploads/2020/06/aUt7LB5b-115x115.jpg" class="attachment-best-widgetthumb size-best-widgetthumb wp-post-image" alt="" title="" srcset="http://truomega.ca/wp-content/uploads/2020/06/aUt7LB5b-115x115.jpg 115w, http://truomega.ca/wp-content/uploads/2020/06/aUt7LB5b-150x150.jpg 150w, http://truomega.ca/wp-content/uploads/2020/06/aUt7LB5b-400x400.jpg 400w, http://truomega.ca/wp-content/uploads/2020/06/aUt7LB5b.jpg 512w" sizes="(max-width: 115px) 100vw, 115px" />											</a>
										</div>
										<div class="post-data">
											<div class="post-data-container">
												<div class="post-title">
													<a href="http://truomega.ca/2020/06/30/b-c-government-announces-6-15-million-funding-for-indigenous-initiatives-in-public-universities/" title="B.C. Government announces $6.15 million funding for Indigenous initiatives in public universities">B.C. Government announces $6.15 million funding for Indigenous initiatives in public universities</a>
												</div>
												<div class="post-info">
													<span class="thetime updated">Jun. 30, 2020</span>
													<span class="thecomment"><i class="fa fa-comments"></i> <a rel="nofollow" href="http://truomega.ca/2020/06/30/b-c-government-announces-6-15-million-funding-for-indigenous-initiatives-in-public-universities/#respond">0</a></span>
												</div>
											</div>
										</div>
									</div>
								</div>
							</li>
							</ul></div><!-- .related-posts -->					                    					
				</div><!--.g post-->
				<!-- You can start editing here. -->
<!-- If comments are open, but there are no comments. -->

	<div id="commentsAdd">
		<div id="respond" class="box m-t-6">
			
		<div id="respond" class="comment-respond">
							<h3 id="reply-title" class="comment-reply-title">Leave a Reply					<small><a rel="nofollow" id="cancel-comment-reply-link" href="/2020/10/19/the-final-rundown-of-kamloops-candidates-in-b-c-general-election/#respond" style="display:none;">Cancel reply</a></small>
				</h3>
						<form id="commentform" class="comment-form">
				<iframe src="http://jetpack.wordpress.com/jetpack-comment/?blogid=56539825&#038;postid=20602&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=1&#038;avatar_default=mystery&#038;greeting=Leave+a+Reply&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=5.8.1&#038;sig=213ca122cfca200557125cce61ff5d1d412c567f#parent=http%3A%2F%2Ftruomega.ca%2F2020%2F10%2F19%2Fthe-final-rundown-of-kamloops-candidates-in-b-c-general-election%2F" style="width:100%; height: 430px; border:0;" name="jetpack_remote_comment" class="jetpack_remote_comment" id="jetpack_remote_comment"></iframe>
				<!--[if !IE]><!-->
				<script>
					document.addEventListener('DOMContentLoaded', function () {
						var commentForms = document.getElementsByClassName('jetpack_remote_comment');
						for (var i = 0; i < commentForms.length; i++) {
							commentForms[i].allowTransparency = false;
							commentForms[i].scrolling = 'no';
						}
					});
				</script>
				<!--<![endif]-->
			</form>
		</div>

		
		<input type="hidden" name="comment_parent" id="comment_parent" value="" />

				</div>
	</div>
					</div>
	</article>
    <aside id="sidebar" class="sidebar c-4-12" role="complementary" itemscope itemtype="http://schema.org/WPSideBar">
	
<!-- WordPress Popular Posts Plugin [W] [weekly] [views] [regular] -->

<div id="wpp-2" class="widget popular-posts">
<h3 class="widget-title">Popular posts</h3>
<ul class="wpp-list">
<li>
<a href="http://truomega.ca/2020/10/14/trus-nursing-and-population-health-building-opens-for-use/" title="TRU’s Nursing and Population Health Building opens for use" class="wpp-post-title" target="_self">TRU’s Nursing and Population Health Building opens for use</a>
 <span class="wpp-meta post-stats"><span class="wpp-date">posted on Oct. 14, 2020</span> | <span class="wpp-category">under <a href="http://truomega.ca/category/news/" class="category category-5">News</a></span></span>
</li>
<li>
<a href="http://truomega.ca/2020/10/14/students-engage-in-dialogue-surrounding-indigenization-at-tru/" title="Students engage in dialogue surrounding indigenization at TRU" class="wpp-post-title" target="_self">Students engage in dialogue surrounding indigenization at TRU</a>
 <span class="wpp-meta post-stats"><span class="wpp-date">posted on Oct. 14, 2020</span> | <span class="wpp-category">under <a href="http://truomega.ca/category/news/" class="category category-5">News</a></span></span>
</li>
<li>
<a href="http://truomega.ca/2020/10/14/coping-with-the-ongoing-covid-19-pandemic-as-a-student/" title="Coping with the ongoing COVID-19 pandemic as a student" class="wpp-post-title" target="_self">Coping with the ongoing COVID-19 pandemic as a student</a>
 <span class="wpp-meta post-stats"><span class="wpp-date">posted on Oct. 14, 2020</span> | <span class="wpp-category">under <a href="http://truomega.ca/category/culture/" class="category category-2">Culture</a></span></span>
</li>
<li>
<a href="http://truomega.ca/2020/10/14/trusu-is-keeping-busy-during-the-2020-21-school-year/" title="TRUSU is keeping busy during the 2020/21 school year" class="wpp-post-title" target="_self">TRUSU is keeping busy during the 2020/21 school year</a>
 <span class="wpp-meta post-stats"><span class="wpp-date">posted on Oct. 14, 2020</span> | <span class="wpp-category">under <a href="http://truomega.ca/category/news/" class="category category-5">News</a></span></span>
</li>
<li>
<a href="http://truomega.ca/2020/10/14/indigenous-tru-seeking-creative-solutions-to-tackle-obstacles-presented-by-the-pandemic/" title="Indigenous TRU seeking creative solutions to tackle obstacles presented by the pandemic" class="wpp-post-title" target="_self">Indigenous TRU seeking creative solutions to tackle obstacles presented by the pandemic</a>
 <span class="wpp-meta post-stats"><span class="wpp-date">posted on Oct. 14, 2020</span> | <span class="wpp-category">under <a href="http://truomega.ca/category/news/" class="category category-5">News</a></span></span>
</li>
<li>
<a href="http://truomega.ca/2020/10/14/tru-star-athlete-playing-on-two-separate-teams-for-the-wolfpack/" title="TRU star athlete playing on two separate teams for the Wolfpack" class="wpp-post-title" target="_self">TRU star athlete playing on two separate teams for the Wolfpack</a>
 <span class="wpp-meta post-stats"><span class="wpp-date">posted on Oct. 14, 2020</span> | <span class="wpp-category">under <a href="http://truomega.ca/category/sports/" class="category category-8">Sports</a></span></span>
</li>
</ul>

</div>
<div id="mts_recent_posts_widget-2" class="widget widget_mts_recent_posts_widget horizontal-small"><h3 class="widget-title">Recent Posts</h3><ul class="advanced-recent-posts">			<li class="post-box horizontal-small horizontal-container"><div class="horizontal-container-inner">								<div class="post-img">
					<a href="http://truomega.ca/2020/10/19/the-final-rundown-of-kamloops-candidates-in-b-c-general-election/" title="The final rundown of Kamloops candidates in B.C. General Election">
													<img width="115" height="115" src="http://truomega.ca/wp-content/uploads/2020/10/119905121_10158552387981287_8853202147978197337_o-115x115.jpg" class="attachment-best-widgetthumb size-best-widgetthumb wp-post-image" alt="" title="" />											</a>
				</div>
								<div class="post-data">
					<div class="post-data-container">
						<div class="post-title">
							<a href="http://truomega.ca/2020/10/19/the-final-rundown-of-kamloops-candidates-in-b-c-general-election/" title="The final rundown of Kamloops candidates in B.C. General Election">The final rundown of Kamloops candidates in B.C. General Election&nbsp;&hellip;</a>
						</div>
												<div class="post-info">
														<span class="thetime updated"><i class="fa fa-clock-o"></i> Oct 19, 2020</span>
																				</div> <!--.post-info-->
																	</div>
				</div>
			</div></li>					<li class="post-box horizontal-small horizontal-container"><div class="horizontal-container-inner">								<div class="post-img">
					<a href="http://truomega.ca/2020/10/14/the-rundown-on-voting-in-the-provincial-general-election/" title="The rundown on voting in the Provincial General Election">
													<img width="115" height="115" src="http://truomega.ca/wp-content/uploads/2020/06/aUt7LB5b-115x115.jpg" class="attachment-best-widgetthumb size-best-widgetthumb wp-post-image" alt="" title="" srcset="http://truomega.ca/wp-content/uploads/2020/06/aUt7LB5b-115x115.jpg 115w, http://truomega.ca/wp-content/uploads/2020/06/aUt7LB5b-150x150.jpg 150w, http://truomega.ca/wp-content/uploads/2020/06/aUt7LB5b-400x400.jpg 400w, http://truomega.ca/wp-content/uploads/2020/06/aUt7LB5b.jpg 512w" sizes="(max-width: 115px) 100vw, 115px" />											</a>
				</div>
								<div class="post-data">
					<div class="post-data-container">
						<div class="post-title">
							<a href="http://truomega.ca/2020/10/14/the-rundown-on-voting-in-the-provincial-general-election/" title="The rundown on voting in the Provincial General Election">The rundown on voting in the Provincial General Election&nbsp;&hellip;</a>
						</div>
												<div class="post-info">
														<span class="thetime updated"><i class="fa fa-clock-o"></i> Oct 14, 2020</span>
																				</div> <!--.post-info-->
																	</div>
				</div>
			</div></li>					<li class="post-box horizontal-small horizontal-container"><div class="horizontal-container-inner">								<div class="post-img">
					<a href="http://truomega.ca/2020/10/14/trusu-is-keeping-busy-during-the-2020-21-school-year/" title="TRUSU is keeping busy during the 2020/21 school year">
													<img width="115" height="115" src="http://truomega.ca/wp-content/uploads/2019/09/TRUSU-1-115x115.jpg" class="attachment-best-widgetthumb size-best-widgetthumb wp-post-image" alt="" title="" />											</a>
				</div>
								<div class="post-data">
					<div class="post-data-container">
						<div class="post-title">
							<a href="http://truomega.ca/2020/10/14/trusu-is-keeping-busy-during-the-2020-21-school-year/" title="TRUSU is keeping busy during the 2020/21 school year">TRUSU is keeping busy during the 2020/21 school year&nbsp;&hellip;</a>
						</div>
												<div class="post-info">
														<span class="thetime updated"><i class="fa fa-clock-o"></i> Oct 14, 2020</span>
																				</div> <!--.post-info-->
																	</div>
				</div>
			</div></li>					<li class="post-box horizontal-small horizontal-container"><div class="horizontal-container-inner">								<div class="post-img">
					<a href="http://truomega.ca/2020/10/14/looking-for-a-spot-to-bunker-down-and-study/" title="Looking for a spot to bunker down and study?">
													<img width="115" height="115" src="http://truomega.ca/wp-content/uploads/2020/10/bonnie-kittle-GiIZSko7Guk-unsplash-115x115.jpg" class="attachment-best-widgetthumb size-best-widgetthumb wp-post-image" alt="" title="" />											</a>
				</div>
								<div class="post-data">
					<div class="post-data-container">
						<div class="post-title">
							<a href="http://truomega.ca/2020/10/14/looking-for-a-spot-to-bunker-down-and-study/" title="Looking for a spot to bunker down and study?">Looking for a spot to bunker down and study?&nbsp;&hellip;</a>
						</div>
												<div class="post-info">
														<span class="thetime updated"><i class="fa fa-clock-o"></i> Oct 14, 2020</span>
																				</div> <!--.post-info-->
																	</div>
				</div>
			</div></li>		</ul>
</div><div id="reallysimpletwitterwidget-3" class="widget widget_reallysimpletwitterwidget"><h3 class="widget-title">The Omega on Twitter</h3>
      <ul class="really_simple_twitter_widget"><li>The final rundown of Kamloops candidates in B.C. General Election <a href="https://t.co/Da5fKFq2Wu" class="twitter-link" >https://t.co/Da5fKFq2Wu</a> <a href="http://twitter.com/#!/search?q=%23kamloopsbc" class="twitter-link" >#kamloopsbc</a> <a href="http://twitter.com/#!/search?q=%23kamloops" class="twitter-link" >#kamloops</a><span class="rstw_comma">,</span> <span class="twitter-timestamp" title="2020/10/19 15:27">1 hour ago</span></li><li>TRU star athlete playing on two separate teams for the Wolfpack <a href="https://t.co/VnRHwt3m9c" class="twitter-link" >https://t.co/VnRHwt3m9c</a><span class="rstw_comma">,</span> <span class="twitter-timestamp" title="2020/10/19 15:22">1 hour ago</span></li><li>TRU undefeated after their first round of exhibition games <a href="https://t.co/DZhbaspPwZ" class="twitter-link" >https://t.co/DZhbaspPwZ</a><span class="rstw_comma">,</span> <span class="twitter-timestamp" title="2020/10/17 09:38">Oct 17</span></li><li>Coping with the ongoing COVID-19 pandemic as a student <a href="https://t.co/kAIpkwHj74" class="twitter-link" >https://t.co/kAIpkwHj74</a><span class="rstw_comma">,</span> <span class="twitter-timestamp" title="2020/10/16 08:04">Oct 16</span></li><li>Indigenous TRU seeking creative solutions to tackle obstacles presented by the pandemic <a href="https://t.co/tc3knv6tPf" class="twitter-link" >https://t.co/tc3knv6tPf</a>… <a href="https://t.co/VqdawP1pQX" class="twitter-link" >https://t.co/VqdawP1pQX</a><span class="rstw_comma">,</span> <span class="twitter-timestamp" title="2020/10/15 06:58">Oct 15</span></li></ul></div></aside><!--#sidebar-->
		</div><!--#page-->
	</div><!--.main-container-->
	<footer>
				
			<div class="container">
						<div class="c_footersearch"><form method="get" id="searchform" class="search-form" action="http://truomega.ca" _lpchecked="1">
	<fieldset>
		<input type="text" name="s" id="s" value="" placeholder="Search the site"  />
		<button id="search-image" class="sbutton" type="submit" value="">
	    		<i class="fa fa-search"></i>
	    	</button>
	</fieldset>
</form>
</div>
			</div>
			
		<div class="copyrights">
			<div class="container">
				<!--start copyrights-->
<div id="copyright-note">
<span><a href="http://truomega.ca/" title="Thompson Rivers University&#039;s Independent Student Newspaper" rel="nofollow">The Omega Student Newspaper Ω</a> Copyright &copy; 2020.</span>
<div class="right"><div class="secretarea"><span class="stateone">Ω</span><span class="statetwo" title="It's like this little electronic shadow on each and everyone of us">Π</span></div></div>
</div>
<!--end copyrights-->
			</div><!--.container-->
		</div><!--.copyrights-->
	</footer><!--footer-->
</div><!--.main-container-wrap-->
    	<div style="display:none">
	</div>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"http:\/\/truomega.ca\/2020\/10\/19\/the-final-rundown-of-kamloops-candidates-in-b-c-general-election\/":20602};
	</script>
	<div id="sharing_email" style="display: none;">
		<form action="/2020/10/19/the-final-rundown-of-kamloops-candidates-in-b-c-general-election/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
			
			<img style="float: right; display: none" class="loading" src="http://truomega.ca/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
		<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"http:\/\/truomega.ca\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}}};
/* ]]> */
</script>
<script type='text/javascript' src='http://truomega.ca/wp-content/plugins/contact-form-7/includes/js/scripts.js'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js'></script>
<script type='text/javascript' src='http://truomega.ca/wp-includes/js/jquery/ui/core.min.js'></script>
<script type='text/javascript' src='http://truomega.ca/wp-includes/js/jquery/ui/widget.min.js'></script>
<script type='text/javascript' src='http://truomega.ca/wp-includes/js/jquery/ui/mouse.min.js'></script>
<script type='text/javascript' src='http://truomega.ca/wp-includes/js/jquery/ui/draggable.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"http:\/\/truomega.ca\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://truomega.ca/wp-content/plugins/wp-polls/polls-js.js'></script>
<script type='text/javascript' src='http://s.gravatar.com/js/gprofiles.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://truomega.ca/wp-content/plugins/jetpack/modules/wpgroho.js'></script>
<script type='text/javascript' src='http://truomega.ca/wp-includes/js/comment-reply.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jpfbembed = {"appid":"249643311490","locale":"en_US"};
/* ]]> */
</script>
<script type='text/javascript' src='http://truomega.ca/wp-content/plugins/jetpack/_inc/build/facebook-embed.min.js'></script>
<script type='text/javascript' src='http://truomega.ca/wp-includes/js/wp-embed.min.js'></script>
<script async="async" type='text/javascript' src='http://truomega.ca/wp-content/plugins/akismet/_inc/form.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://truomega.ca/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-linkedin', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-google-plus-1', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomgoogle-plus-1', 'menubar=1,resizable=1,width=480,height=550' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-pocket', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcompocket', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-tumblr', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtumblr', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
</script>

		<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
		<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "http://jetpack.wordpress.com/jetpack-comment/?blogid=56539825&postid=20602&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=5.8.1&sig=213ca122cfca200557125cce61ff5d1d412c567f#parent=http%3A%2F%2Ftruomega.ca%2F2020%2F10%2F19%2Fthe-final-rundown-of-kamloops-candidates-in-b-c-general-election%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "http://jetpack.wordpress.com/jetpack-comment/?blogid=56539825&postid=20602&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=5.8.1&sig=213ca122cfca200557125cce61ff5d1d412c567f#parent=http%3A%2F%2Ftruomega.ca%2F2020%2F10%2F19%2Fthe-final-rundown-of-kamloops-candidates-in-b-c-general-election%2F";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "http:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						}
					}
				})

			})();
		</script>

		<script type='text/javascript' src='https://stats.wp.com/e-202043.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:5.8.1',blog:'56539825',post:'20602',tz:'-7',srv:'truomega.ca'} ]);
	_stq.push([ 'clickTrackerInit', '56539825', '20602' ]);
</script>
</body>
</html>